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Summary andwork-flow

This tutorial explains the work-flow to set-up and run a 2D Flow Simulation in Simcenter NX12. Its targeted
audience is anyone without any particular prior knowledge of NX Simcenter Environment. It explains in de-
tails the basic actions in order to perform a simple fluid simulation. It ismeant to be used as a quick-guide to
lead rapidly to a first solution. The reader can o� course refer to the o�icial NX help for any required further
explanation or when his needs deviate from the simple example presented in this document. The tutorial is
based on a simple test case : the study of a 2D turbulent incompressible flow in curved pipe. The following
list explains in brief the work-flow andmain steps needed to perform a flow simulation in SimCenter NX12.

1. Create the fluid domain (.prt file)

— The fluid domain for the simulation has to be created by using the internal CADwithin Simcenter
NX. Basically, for a 2D simulation, the geometry is completely defined with the sketcher. A solid
body is then created by extruding the sketch to a small thickness.

— To prepare the meshing, the solid body can be split into multiple simple geometric shapes.
— At the end of this step, you shall have a saved yourproject.prt file.

2. Mesh the body (.fem file)

— The fluid domain is meshed using the internal mesher of Simcenter NX.
— First, meshing constraints have to be set on the edges of the bottom face of the body : number
on edge, size on edge or biasing on edge (for a boundary layer).

— Then, 2Dmappedmeshes have be created on all faces of the bottom face of the body.
— The 2Dmeshes are then copied onto the other face and swept along the thickness of the part in
order to generate 3Dmeshes with only one element along the thickness.

— At the end of this step, you shall have a saved yourproject_fem.fem file

3. Specify material properties and set the simulation constraints (.sim file)

— Di�erent simulation objects have to be created : fluid materials, boundary conditions, initial
conditions. At this stage, some measurements of interest for the simulation analysis have to be
defined : force on a face, min/max velocity/pressure within a given area,...

— At the end of this step, you shall have a save yourproject_sim.sim file, ready to be “solved”.

4. Solve the simulation

— The solution attributes have to be set : steady state or transient, turbulencemodel, usewall func-
tion or not, data fields to be retrieved,...

— The solver parameters have to be set : relaxation time step, convergence criteria, number of ite-
ration limits,...

— Finally the simulation can be run. At the end of this step, you shall have run the simulation and
the solution shall have converged (or not) to a result a�er some iterations.

5. Export and analyse the simulation results

— The solution verbose and the convergence graph should be reviewedwithin the “SolutionMoni-
tor” window.

— The results can be loaded in order to plot the field of interest : velocity, pressuremaps, 2D graph
along a path, streamlines, ... A html report with extra results (force on a face for instance) is also
generated if it was defined at step 3.

— At the endof this step, you can save again yourworking .sim file as a reference before experimen-
ting with di�erent meshes, constraints or solver parameters.

Each step will be explained with more details using a practical example in the following chapters. Extra do-
cumentation about workflow for Flow simulation can be found here :
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128419:index_advanced:id1245911:
id629501

https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128419:index_advanced:id1245911:id629501
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128419:index_advanced:id1245911:id629501
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Physical context of the tutorial

We consider a 2D flow in a pipe (unit depth) of water (incompressible, viscous, steady-state). The velocity
at inlet is uniform at U1 = 0.34m/s and the outlet is at ambient pressure (p2 = 0 Pa in relative). The pipe
diameter is D = 65 mm and its total length is L = 2.78 m. This tutorial will compute the entire flow but
under some assumptions, we can estimate theoretically the pressure drop∆p = p1 − p2 between the inlet
and the outlet, due to viscous loss.

DU1

p2

u

Because the fluid is viscous, it is not allowed to useBernoulli equation. Nevertheless, by neglecting entrance
e�ects and taking the mean velocity ū = U1, the pressure loss can be computed with the Darcy–Weisbach
equation (adapted from a 3D cylindrical pipe to a 2D plane pipe),

∆p = f
L

4D
ρU2

1

with f the Darcy friction factor, obtained (experimentally) for a turbulent flow in a smooth pipe (here,Re =
U1D
ν = 2.2 104 > 2000 thus turbulent) with 1√

f
= 2 log(Re

√
f) − 0.8 or with Moody diagram. We found

f = 0.0253 and thus∆p = 31.2 Pa.

Physically, themost important part to understand in thenumerical setup in theboundary conditions choice.
The fluid is entirely described by Navier-Stokes (NS) equations (di�erential equations for 4 unknowns : 3
components foruand 1 forp). 4 boundary conditions are thusneeded to solve the computation. Velocity and
pressure are linked together thanks to NS equations, when one is known, the other to. Boundary conditions
areneeded for thewhole control surface.Here, the velocity is imposedat the inlet (3 values) and thepressure
at the outlet (1 value). The rest of the control surface is a wall, for which the condition is a no slip wall (here,
we have a viscous flow, with zero velocity at the wall). When the flow is turbulent, a special treatment of the
wall has to be done, using a wall function (modelling the turbulent boundary layer, more details in section
7.1. If the flow is inviscid the condition is a slip wall (or equivalently, impose a zero velocity across the wall).
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1 Create the fluid domain

Before toopenNX12, be sure that youare connected to thenetworkofULiege (via theVPNBIG-IP EdgeCLient
). If you connect for the first time, type Licensing Tool in StartMenu and select these bundles. A�erwards, you
can start NX12.

1.1 Create an emptymodel

File > New > under tab “Model” select “Model” > OK
Be sure to create the file inside a new folder, on your Desktop for example, or in a place where you have
written access. All next files will be linked to this first file. when NX will computes results, they will be saved
in this chosen folder.

https://my.segi.uliege.be/cms/c_11650735/fr/mysegi-new-vpn
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You shall have this view and you are ready to create your part.

NX12 is based on an tree structure (the le� blank panel) where you can check what you have done, go back
and modify previous steps. If you have several files opened in NX12, click on the top tab Switch window

to navigate.

To navigate in space, you can use rather navigation icons or using a mouse :

— Useful shortcuts are available when holding down the right mouse button.
— Clicking the central mouse button and dragging will rotate the view.
— Clicking the central mouse button, then the right mouse button and dragging will move the view. You
cando the samemoreeasilybyholdingdowntheSHIFTkeyandclickingonly thecentralmousebutton
and dragging.

— Rolling the mouse wheel will zoom in/out.
— As you work in a sketch plane, if you unintentionally moved the view out of plane, you can use short-
cut SHIFT+ F8 to get back to the top view. You can also choose a point of view (on a plane, isomeric...)
using

1.2 Create a 2D sketch

Click “Sketch” in the upper le� corner .
You can keep the default coordinate axis > OK
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1.3 Draw the fluid domain

Draw the fluid domain and eventual obstacles using the tools under Direct Skecth : Rectangle, Line, Arc,...
Here, we have an internal flow, sowe draw the fluid inside the pipe. For an external flow around a body, your
fluid domain will be what is around the body.

Draw the following sketch using the Line command. The dimensions do not have to be the same at this
moment, only the general shapematters.

Closed sketch : To be sure that your sketch is a closed contour (to be able to create a solid body in section
1.5), be sure that you select the same point when drawing intersecting lines (orange point). NX12 helps you
to draw vertical or horizontal line by adding some orange dashed lines.

Delete : If you want to delete/modify an element, be sure to deselect the tool you used first (if you not, you
will still be in drawing mode). Right click on the element you want to delete and select (or click on the
element and CTRL+D).

Element selection : The di�erent elements are selected just by clicking them successively, there is not need
to hold downCTRL key. To deselect all : press ESC. To deselect one itemonly : click it with le�mouse holding
down SHIFT

Dimensions and constraints : Youwill see that grey dimensions appear automatically in such away to fully
define your sketch. These are auto-dimensions but not constraints so your sketch is free to move. To add
constraints, you can either
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1. Double-click on grey dimension and adjust the value to make them constraints, they will appear in
dark blue color.

2. Select a segment, right click and then choose horizontal/vertical dimensions

3. Add more complex constraints, like parallelism, same length, perpendicularity, etc.. by selecting suc-
cessively di�erent elements and then choosing suggested constraints.
Dimensions constraints can be found under Direct Sketch > "Rapid Dimension". You can also find all
constraints under Direct Sketch > More > "Sketch Constraints"

For this tutorial you should have the following constraints.

It shouldn’t contain any grey dimensions (auto dimensions) but only dark blue constraints (px = ...). This
means the sketch is fully constrained. "Sketch is fully constrained"will appear at the bottom of the window.
If you have red/purple constraints, it means that your sketch is over-constrained, you should remove some
constraints in this case.
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Draw a round corner : Select the Filet tool in Direct Sketch and then successively the two inner legs of
the corner. Repeat with the two outer legs. You should have the following sketchwith two additional degree
of freedom, being the two arc radius.

To keep a constant section for the pipe, you will select the two horizontal legs of the pipe and force them to
the same length as shown-here below. Because of the other constraints, imposing only the two horizontal
legs is enough.

The only remaining degree of freedom is the radius of the outer arc that you should force to 400mm. The
final sketch should appear as follows.

1.4 Finish the sketch

When you are done with the sketch, Click "Finish Sketch" in the upper le� corner
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1.5 Extrude

Select your sketch >Click "Extrude" under Feature toolbox >Chooseanextrusion length (enddistance) of 10mm
(for example) > OK

By rotating the view with themiddle mouse button you can verify that you have now a 3D solid body (if you
did not have close your sketch, it will be a shell).

1.6 Split body to prepare themeshing

To make a consistent meshing with quadrilateral elements, and be able to apply specific mesh constraints
on domains, the fluid domain has to be divided in simple geometries : triangles or quadrilaterals, possibly
with curved edges. Thus, we will split here the body in 3 parts thanks to two small edges at the connection
between the straight entry and the rounded turn.

Under Feature toolbox > More > Trim > "Split body"



How to set-up and run a 2D Flow Simulation in Simcenter NX12 11/34

Select your body, choose "Extrude" under Tool Option and then under Tool > Section > Select Curve > Click on
"Sketch Section".

Draw split limit : A�er clicking on "Sketch Section", you will enter in a temporary sketch, where you have to
first select the system coordinate (same as before, CSYS).
You should split the body in three parts by adding twoperpendicular lines at the entry and exit of the corner.
You should also have this new sketch fully constrained. When you are done with the sketch, Click "Finish
Sketch" in the upper le� corner.

Make sure to tick the box for “Keep Imprinted Edges” under Settings and click OK. By doing so, the so�ware
automatically createsGlue Coincident typemeshmating conditions between the bodieswhen you switch to
theFEM file. You should inspect thesemating conditionsandensure that theywere createdat all appropriate
locations
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When drawing split limits, your elements should referring to the first sketch geometry. By doing so, if you
change a dimension in the first sketch later, this split body and the meshing will follow and adapt automa-
tically. If you want to split the body in more complex parts inside a body part, start from the new split body
part and re-do a split body procedure (example in section 6. You should end up with this design,

Make sure you save your model as a yourproject.prt file. Do not hesitate to save it o�en using CTRL+S.

Sketch tutorials can be found here :
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:id1251042
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128417:index_sketcher:id188016:id771117

Sketch video examples can be found here :
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128417:index_sketcher:id1389302

https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:id1251042
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128417:index_sketcher:id188016:id771117
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128417:index_sketcher:id1389302
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2 Mesh the body

2.1 Create amesh file

— File > New > under tab “Simulation” select “Simcenter Thermal/Fow” with type “Fem” > OK Be sure to
save it in the same folder as the .prt file, under another name (using name_fem.fem for example).

— Keep the box “Associate to Master Part” ticked.

— In the field “Part”, you shall select the part you just created.

— Untick the box “Create Idealized Part”. This option is used when working in team on the same part or
if the part has to be simplified for the simulation but the original design has to kept unaltered.

— Select Solver “Simcenter Thermal/Flow” and Analysis Type “Flow”. Click OK.
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2.2 Verify that the di�erent split bodies are connected

First thing to do, is to verify that the di�erent polygons created by the split body command are correctly
connected to each other. It is OK if there are two elements under Connection Collectors > MMC Collection >
mmc_split (Mesh Mating Conditions, just check if they are present).

If it appears that two polygon bodies have common face but are not connected, you can add the connection
manually by clicking Mesh Mating under Connections toolbox.

2.3 Add themeshing constraints on the body edges

Mesh Control > choose in the dropbox the constraint you want > Select all edges for which you want to apply
the constraints > Click the preview button > OK.
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Here, we will set the mesh constraints, on one face only (upper face of the extrude, be sure to select always
edges from the same face).

Biasingonedge :wewill apply on the 4perpendicular section a “bias on edge”with option “Center of edge”,
30 elements and bias ratio of 1.12 to have smaller elements close to thewall where the velocity gradients are
more important. The orientation of the orange arrow does not matter here because the biasing is centered.
Remark : Amatching edge between two polygons should be specified once only. NX12 automatically applies
the mesh constraint on both sides.

Size on edge : Next, you force the elements size to be 10mm on the entry and exit lateral sections. You shall
put all those constraints in the same plane, here the upper plane.

Repeat the same operation and set a size on edge of 5mm on the outer arc of the corner.

Number on edge : you shall also set the short edges along the thickness (z-axis) to have one single element,
as the simulation is 2D. Do not hesitate to zoom a lot on the thickness and to rotate the view to be sure only
the small thickness edge is selected.
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Tips : You can set a constraint on multiple edges at a time. For the biasing on edge (especially useful for
boundary layer), you have to select the orientation (start of edge, end of edge or middle of edge) and it
varies from edges to edges depending on the edge natural direction.
You can always modify constraints already defined by double click on it in the arborescence. You can also
rename the constraint to identify it more easily.

Formore complex geometry, you can set the view to static wireframe to view all your constraints at once. An
edge density is shown with a yellow diamond, see here-under.

2.4 Create 2Dmeshes

You can nowmesh the face by using 2D mapped mesh. Of course you should mesh the plane on which you
defined the mesh constraints. Make sure to create one 2D mesh per face at one time (we have 3 bodies in
this case), to obtain 3 meshes and be able to use the 2D dependent option (see section 2.5).

Mesh > More > "2D Mapped" > Click the face where you set the edge constraints. Select either QUAD4 or TRI3
elements. In this tutorial we select quad (structured) elements. When working with quadrilaterals mesh, if
you have correctly set the edge constraints, the “Element Size” parameter should have no e�ect and can be
le� to a default value. Click the icon next to “Show Result” to get the preview before clicking OK.
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Mesh all the other polygon faces of the plane similarly (3 in total). Inmore complex geometry,make sure not
to over-constrain the mesh. At the end, you obtain 3 shells below "2D Collectors". Each shell contains a 2D
mapped mesh (3 for the 3 parts of the upper face only) : do not mesh the face along the thickness, this will
be done in the 3Dmesh section.

Every time you generate a 2Dmappedmeshwith quadrilateral elements, the constraint of one edge is repor-
ted to the opposed edge. This constraint appears as “Mapped Mesh Edge Density” in the arborescence and
as blue diamond in the main view (see image here- above). This also means there might be a logical order
on how tomesh the di�erent faces.

2.5 Create 2D dependent meshes on the other face

In order to have a pure bidimensional problem, themesh has to be identical on both upper and lower faces
of the solid. To save time, we can copy paste the upper 2D mesh of each upper face on the bottom one,
thanks to 2D dependent mesh option (proceed for the 3 existing 2Dmeshes separately).

Mesh > More > "2D dependent" > Select the master (upper) face (already meshed) > Select the corresponding
face on the opposite side (lower) as the target face > OK.

Repeat the process for all 2D meshes separately. Sometimes, the selection of the upper face as the "Master
Face" is not possible/easy : in this case, check that you have created one 2D mesh for each upper face (see
section 2.4) and rotate the view in 3D to be able to select it.

Now, all 3 shells (below "2D Collectors") contain two 2D meshes (the "2D Mapped" and the "2D dependent"
ones, see the figure below in section 2.6).
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2.6 Create 3D sweptmesh

At this stage, when only have 3 shells, each one composed of 2 parallel 2D meshes (upper and lower faces).
Wewill construct the 3Dmesh by sweeping the 2Dmeshes (for the 3 bodies separately). Wewill now use the
mesh constraint along the thickness.

Mesh > More > "3D Swept Mesh" > Type "Until target" > Click the upper face with the 2D mapped mesh, then
click in the dialog box to select the target face and click on the lower face of your polygon > OK

You should use HEXA8 if you have 2Dmap with QUAD4 elements. Here again, the “Source Element Size” pa-
rameter should have no e�ect if you had correctly set a constraint of 1 single element on the edges along
thickness.

Proceed similarly for all the 3 polygonbodies. Youwill obtain 3 Solids under "3DCollectors", each one contai-
ning a 3Dmesh. You can verify that you have well a 3Dmesh with only one element for the whole thickness
and that the top and bottom meshes match such that the elements are vertical prisms. You can again use
the static wireframe view.

Do not forget to save your project as yourproject_fem.fem

Remark : Even if the extension changes from the yourproject.prt, it seems it can’t have the same name and
you should append _fem to the file name.



How to set-up and run a 2D Flow Simulation in Simcenter NX12 19/34

3 Specify material properties and set the simulation constraints

3.1 Create a sim file

— File > New > under tab “Simulation” select “Simcenter Thermal/Fow” with type “Sim” > OK
— In the field “Associated FEM”, you shall select the fem file you just created.
— At this stage under Solver Environment/Analysis type, it appears “Thermal” instead of “Flow” but you
will be able to change it on the next dialog box.

— A�er changing the Analysis Type to "Flow", Click OK, as it will still be possible to change all these solu-
tion attributes before running the simulation.

3.2 Set thematerials

In the arborescence, expand the "3D Collectors" and double-click every single "Solid". Then, on the le� of
"Type", click on the symbol ø toX "Apply Override" for both the "Type (Pure Substance)" and the "Material".
On the right of "Material (None)", select "Choosematerial" and then select thematerial substancewithin the
catalog : "Water" for this tutorial. Repeat the same for every single "Solid".

3.3 Set the boundary conditions

3.3.1 FlowBoundaryCondition : Define the inlet andoutlet conditions : LoadsandConditions >Simulation
Object Type > "Flow Boundary Conditions"
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— Inlet Flow : to set a velocity (input). In this tutorial, you will set "Velocity" Mode to 0.34 m/s (input
velocity at the extremity of long leg of the pipe (on the inlet face)).

— Opening : to set a pressure (output). Select External Conditions "Ambient" pressure at the extremity of
the short leg (outlet face).

3.3.2 Symmetry Plane : On the upper (and lower) face of the solid, you can impose "Symmetry Plane" to
ensure a pure bi-dimensional problem. You can select all faces on one side simultaneously (all 3 faces on the
upper surface for example then apply and proceed the same for all 3 faces on the bottom surface), butmake
sure not to select upper and lower faces together.

3.3.3 Boundary FlowSurface : The faces along the thickness (6 polygon faces in total) represent thewalls
of the pipe. For them, choose "Flow Surface", with a "Type" of "Boundary Flow Surface". For the "Wall Treat-
ment", select either "Slip Wall" (inviscid fluid) or "Non-Slip Wall" (viscous fluid, zero velocity at the wall), de-
pending on the problem. At the end every single face should have a boundary condition. For laminar flow,
you can keep "Non-SlipWall" butwhen you use a turbulencemodel, you have to change it to “Wall Function”
(see section 7.1).
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You can rename and change the color of the boundary conditions. You can untick the box later in the tree
structure (under Simulation Objects) for more clarity.

3.4 Set the initial conditions

Loads and Conditions > Constraint Type > Initial Conditions

Setting the initial conditions should speed up the convergence to the solution. In this tutorial, this is not
necessary.

3.5 Prepare report for forces on walls

At this point, youwill prepare the computationof the forces on thewalls (the corner and the legs of thepipe).

Simulation Object Type > Report > Type "Li� & Drag". Click the surfaces of interest (i.e. the walls, thus the 6
faces along the thickness, as done in the figure below).

In the subpanel “Axes” you should select the coordinate system as previously defined and choose the right
orientation for Li� and Drag Axis.

You can also enter some data to compute directly the aerodynamic coe�icient if applicable, like the density
ρ (this is not the case for this tutorial).

Do not forget to save your project as yourproject_sim.sim. Even if the extension changes from the your-
project.prt, it seems it can’t have the same name and you should append _sim to the file name.

Before running the simulation, check that boundary conditions are active and that all the 3 files (.prt, .fem
and .sim) are in the same folder.
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4 Solve the simulation

4.1 Set the solution attributes

Solution > Solve > "Edit Solution Attributes". Make sure Analysis Type is “Flow”

Under Solution Details :

— You can select the Solution Type “Steady state” or “Transient”. In this tutorial, you should start with
steady-state.

— You can select the turbulence model. The common one to be used is "K-Epsilon".

— Under 3D Flow, you should enable Use Wall Function.

— Under Results Options, you should tick any data field you want to retrieve.

4.2 Set the solver parameters

Solution > Solve > Edit Solver Parameters

In some cases, you might need to play with the “Steady-State Relaxation Time Step” and the “Time Step”
under the 3D Flow Solver tab. It has to respect the Courant–Friedrichs–Lewy (CFL) condition U∆t/∆x ≤ 1,
with U the velocity (m/s),∆t the time step and∆x the minimal mesh size. You can also change the "Maxi-
mumResiduals"of the numerical solver, in order to study the convergenceof the solutionbasedon themesh
refinement.
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4.3 Solve the simulation

Solution > Solve > OK

During the computation, you have two windows : Information showing eventual errors or warnings and the
Solution Monitor. On this window, you can click Graph(s) > Convergence to check the progress of the com-
putation in real time and/or watch the verbose in real-time (check the residuals). Under Graph(s) > Track
Results, you can also track in real-time min/max/average velocity/pressure convergence. It is important to
check that your solution has converged, i.e. that the numerical transient phase is finished (the flow needs
time to set-up, from rest to the conditions you specified) and that your global quantities reach a plateau.

Export : you can export the graph of convergence/results in .png directly or in .csv to plot it a�er inMatlab.
Remark : As the simulation is purely bi-dimensional, the residual for W (velocity along z-axis) is constant
at 10−12. This is a quick check for any mistake that could make the flow not purely bi-dimensional. Once,
you could run the simulation and it converged, do not forget to save before analyzing the results and trying
di�erent configurations.
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5 Analyze the simulation results

5.1 Review the verbose

ClickYes to reviewall the solver verbose.There is veryvaluable information tounderstandbetter thesolution
and howworked the solver.

5.2 Check the created files

.log : The logging remain available under a yourproject_sim-Solution_1.log file created in the main
directory folder.
.html : If you have defined a report with Li�&Drag for instance, an .html file should have been created.
.csv : The same info is available in .csv file.
.png : Pictures of convergence graphs. You can also export them as .csv to plot them in Matlab.
flow.csc : Physical constants
flow.fli : Results at each nodes (velocity, pressure,...)
flow.gem : Coordinates of nodes
flow.prm : Numerical parameters
flow.job : CFD information

5.3 Set-up keymeasurements for rapid analysis

Once you have solved at least one time the simulation, you can add some key measures of interest. These
values are handy for a quick lookon the solutionwhen varying di�erent solver parameters or trying di�erent
mesh configuration.

Solution tab > Result Measures

Then, click on the lower le� corner NEW

Pick up values of interest to evaluate validity and convergence of the solution : like minimum pressure over
a surface or maximum velocity over the entire model.

In this tutorial,wewill select theminandmaxvelocity and theminandmaxpressureover theentire domain,
and the average pressure at the inlet.
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5.4 Plot the results

On the very bottom of the three structure, double click on Flow under Results. Then, under Flow, you can
access the di�erent data field : velocity, pressure,... To plot the velocity for instance, Click on Velocity > Ma-
gnitude
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Edit Plot : At the bottom of the tree, right-click the active Post-view > Edit Post View. Or, click directly on
the Edit Post View button on the top tool bar (Results tab). You can choose the Color Display : iso-lines, ar-
rows.... For clarity, you can remove the display of the mesh under Edges & Faces > Edges "Feature" but it is
not recommended to present results during mesh convergence analysis, if results are linked to the mesh.

Streamlines : To plot streamlines, choose Color Display "Streamlines", under Seedset tab, click on Create.
On the Seed Set window, thick Select Nodal Location and Pick "All on face" on the inlet face for example, to
plot streamlines in the whole pipe.

Animation : Click on "Animate" to create an animation of particles on streamlines. You can export it
as .gif file.
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2Dgraph :Once youhaveplotted adata field (velocitymagnitude for example), you can also create 2Dgraph
under Tools toolbox. In this tutorial, we will plot the velocity profile along the pipe :

— Tools > Create Graph
— Under X Axis, Define By "Path Length"
— Under Y Axis, Tick "Define By Query Curve"
— Under the Query curve tab, click the top right icon to create a new curve.
— Give a name to the curve and select

— Method "Nodes ID" and pick up "Nodes" with the pen (by selecting the 2 extremities) or "Nodes
on Edge" (to select directly all nodes on one edge).

— Method "Coordinates" and enter manually the coordinates of 2 points. In this tutorial, we will
createacurveperpendicular to thepipeat500mma�er theentry : upperedgepointat (500,65,0)
and lower at (500,0,0). Finally, enter a high number of points per segment, preferably much hi-
gher than the number of elements, N = 100 for instance.

— When back in the graph tab, make sure the slider for Distance to Mesh is at the minimum 0.0001 and
select the Projection Vector to be along z-axis.

— If the "OK" button remains gray and not selectable, try to reverse the direction of the curve by clicking
on , below the curve creation button.

A�er OK, a small pop-up window will then ask you if you want to plot it in a new window or in an existing
one, chose to Create NewWindow.
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Plot di�erent 2D graphs on same window : Repeat the same steps to plot the velocity profile at di�erent
lengths. When you have your plots under Graphs tab (in the tree structure), select all plots that you want,
right click Plot.

You get then several curves showing the velocity profile at di�erent lengths from the entry. The turbulent
flow profile goes from flat at the inlet (uniform profile at inlet) to a parabolic curve as the boundary layers
grow andmerge. Within the curve, the profile becomes asymmetric with higher velocity at the inner side of
the curve.

Export 2D graph :On a GraphWindow, cllick on Toolbar and then Save Graph. When you have several plots,
choose which one to Export and select .csv as file format (to import and show in Matlab for example).

A tutorial on how to plot the solution is available here (steps 6 to 9) :
https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help/training/en_US/advanced_
sim_tutorial/id741086.html

https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help/training/en_US/advanced_sim_tutorial/id741086.html
https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help/training/en_US/advanced_sim_tutorial/id741086.html
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6 Change the design

In this paragraph, we will show how to test an alternative design, for instance a shorter radius corner.

— First click the top-le� icon Return to home to exit the result analysis and go back to the simula-
tion navigator.

— In the tree structure,underyourproject_sim.sim/yourproject_fem.femdouble-clickyourpart.prt
two times in a row toopen it again.Nowyoucan switchbetween thepart, themeshand the simulation
via the button in the header bar Switch Window.

— When in theModeling window (.prt), select the Part Navigator (3rd icon in the le� vertical toolbar).

— Now you can edit your sketch by double-clicking it. Change the radius from 400 to 70mm.

— Click Finish Sketch.

— Switch window to go back to the Simulation.

— In the top-le�, click Activate Meshing

— In the top-le�, click Update, to automatically update themeshing to the new geometry. Then again in

the top le� Activate the Simulation and Solve for this new configuration.

— The same process can be used to change the meshing constraints, if you want to refine the meshing
for instance. You can jump between the .prt, the .fem and the .sim files and they should be linked
together as youmodify them.
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Plot the velocity field using streamlines to see the dead zone a�er the corner.

A�er loading the solution, Under Home tab > Solution > Result Manager you will see that the values are dis-
played in red, you can select them and click the bottom Update button to get the new values.

R = 400mm R = 70mm
Inlet average pressure 35.9 Pa 75.13 Pa
Maximum velocity 0.39 m/s 0.72 m/s
Maximum pressure 38 Pa 81.57 Pa
Minimum pressure -3 Pa -281.58 Pa

As expected, you can see that the inlet pressure is higher, more than twice what was needed for the large
radius. Minimum,maximumpressure andmaximum velocity are also higher in absolute values over the do-
main.

Compared to the analytical prediction (∆p = 31.2 Pa), thepressuredrop for the large radius is slightly higher.
Indeed, we neglected the entry region (the velocity profile is not fully developped and shear stress are the
same along the whole pipe wall). Moreover, the turn at 90° increases the pressure loss and its radius has a
strong influence on∆p.
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7 Change the turbulencemodel or solution type

7.1 Turbulencemodel

The turbulencemodel can be chosen in Solve > Edit Solution Attributes > Solution Details > Turbulence Model
("None" if laminar flow). When using a turbulent model and "Wall Function" as Wall Treatment, you should
select the size of the first node adjacent to the wall by looking at the dimensionless wall coordinate y+ (the
law of the wall). Indeed, the first node P must be located in the lower part of the log-law region, i.e. y+P ∈
[30, 70]. The first node∆yP is located between∆ye/4−∆ye/3 (the size of the first mesh).

This is computedbyselectingY+andTurbulenceModelQuantities (containingYPlus) inResultsOptionsbefore
solving the simulation. The validity of y+ is crucial since the boundary layer has to bewellmodeled. You can
check it by displaying Y Plus in the results. Then, instead of "smooth" colors, select "banded" to highlight
zones of y+. Because y+ is displayed in the whole domain but you are only interested in the values close to
thewall between30and70, you can change theboundaries of the legend.On thearborescence, click onPost
View, Legend tab and under Value Control, select Specified for Legend ExtremeswithMin = 10 andMax = 100
for example. You can find more information about it on the documentation : https://docs.plm.automation.
siemens.com/tdoc/nx/12/nx_help#uid:xid1128419:index_advanced:xid389654:id627221:xid457884

7.2 Solution type

Depending on the problem, you might solve a transient (unsteady) flow. This can be chosen in Solve > Edit
SolutionAttributes>SolutionDetails >SolutionType> "Transient". In this case, youhave to select theTransient
Setup :

— Solution Time Interval : select the physical Start and End Time.

— Time Integration Control : select theNumber of Time Steps or the Time Step size (for the CFL condition).

— Results Sampling : number of Results (at di�erent time steps or Increment) that will be stored and
shown in the solution.

https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128419:index_advanced:xid389654:id627221:xid457884
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help#uid:xid1128419:index_advanced:xid389654:id627221:xid457884
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It is also possible to add Initial Conditions from a specified "Uniform" state or "From Results in Other Direc-
tory", to start from a previous state, which is already computed.

To trigger unsteady phenomena (for example, to force vortex shedding behind a cylinder), you can change
the solver scheme : go to Solve > Edit Solver Parameters > 3D Flow Solver > Advection Schemes and change
"First-order" to "Second-order (SOU)".

8 Troubleshooting

— A part of the model disappears : In some cases, the 3D view can bug and a part of the model may
seem to disappear, as if it were hidden. In this case, you can always go back to any automatic point of
view you want thanks to the navigation shortcuts.
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— 2D dependent mesh : As mentioned, you might have some di�iculties to create the 2D dependent
(not easy to select the Master Face). In this case, check thta you have one 2D mesh for each face and
try to change and rotate the view, or you can re-do on the lower face the same procedure as you have
done for the upper one to construct the 2D Mapped Mesh.

— Unexpected abortion of the solver :

1. Errors in the Information Window :
Embedded Flow Surface = Flow Surface(1)
There are no valid elements on the underlying geometry.
Make sure all geometry is meshed before performing solution.
That is because you selected an Embedded Flow Surface instead of a Boundary Flow Surface for
the walls boundary conditions (section 3.3).

2. Errors in the Solution Monitor :
Processing Lift and Drag Reports...
NX2TMG - Thermal/flow model file builder:
encountered a problem and terminated abnormally.
That is because you select the upper and lower faces (thus faces parallel to the flow) to compute
li� and drag instead of the walls in section 3.5.

— Warning in the Information Window :
Boundary Flow Surface = Flow Surface(1)
Unsupported Particle Tracking will be ignored for this solution.
ThisWarning is not important andwill not a�ect the solution. It concerns only the particle tracking, at
the bottom of the window of the Boundary Flow Surface (in section 3.3 for the walls).

9 Extra Resources

NX 12 help menu :
https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help/#uid:index

Many tutorials are available here :
https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help//training/en_US/advanced_
sim_tutorial/index.html?goto=id557841.html

The Simcenter Flow Solver Reference Manual is available here :
https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help/common/en_US/graphics/
fileLibrary/nx/tdoc_advanced_simulation/flowrefman.pdf

Acommunity forumforSimCenter3Dsimulation isavailablehere :http://community.plm.automation.siemens.
com/t5/3D-Simulation-Simcenter-3D-Forum/bd-p/Simcenter_3DSimcenter_forum

https://docs.plm.automation.siemens.com/tdoc/nx/12/nx_help/#uid:index
https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help//training/en_US/advanced_sim_tutorial/index.html?goto=id557841.html
https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help//training/en_US/advanced_sim_tutorial/index.html?goto=id557841.html
https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help/common/en_US/graphics/fileLibrary/nx/tdoc_advanced_simulation/flowrefman.pdf
https://docs.plm.automation.siemens.com/data_services/resources/nx/12/nx_help/common/en_US/graphics/fileLibrary/nx/tdoc_advanced_simulation/flowrefman.pdf
http://community.plm.automation.siemens.com/t5/3D-Simulation-Simcenter-3D-Forum/bd-p/Simcenter_3DSimcenter_forum
http://community.plm.automation.siemens.com/t5/3D-Simulation-Simcenter-3D-Forum/bd-p/Simcenter_3DSimcenter_forum
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