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How to set-up and run a 2D Flow Simulation in Simcenter NX11

Summary
This tutorial explains the workflow to set-up and run a 2D Flow Simulation in Simcenter
NX11. Its targeted audience is anyone without any particular prior knowledge of NX
Simcenter Environment.

It explains in details the basic actions in order to perform a simple fluid simulation. It is
meant to be used as a quick-guide to lead rapidly to a first solution. The reader can off
course refer to the official NX help for any required further explanation or when his
needs deviate from the simple example presented in this document.

The tutorial is based on a simple test case: the study of a 2D turbulent incompressible
flow in curved pipe.
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 0 Work-Flow

This chapter explains in brief the workflow and main steps needed to perform a flow
simulation in SimCenter NX11.

✔ Step1 : Create the fluid domain 

➔ The fluid domain for the simulation has to be created by using the internal
CAD within Simcenter NX.

➔ Basically, for a 2D simulation, the geometry is completely defined with the
sketcher. A solid body is then created by extruding the sketch to an arbitrary
small thickness.

➔ In order to prepare the meshing, the solid body can be split into multiple
simple geometric shapes.

➔ At the end of this step, you shall have a saved yourproject.prt file.

✔ Step 2 : Mesh the body

➔ The fluid domain is meshed using the internal mesher of Simcenter NX.

➔ First, meshing constraints have to be set on the edges of the bottom face of
the body : number on edge, size on edge or biasing on edge (for a boundary
layer).

➔ Then “2D mapped meshes” have be created on all  polygon faces of  the
bottom face of the body.

➔ The 2D meshes are then copied onto the other face and swept along the
thickness of the part in order to generate 3D meshes with only one element
along the thickness.

➔ At the end of this step, you shall have a saved yourproject_fem.fem file

✔ Step 3 : Specify material properties and set the simulation constraints

➔ Different simulation objects have to be created: fluid materials,  boundary
conditions, initial conditions.

➔ At this  stage,  some measurements of  interest for the simulation analysis
have to be defined : force on a  face, min/max velocity/pressure within a
given area,...

➔ At the end of this step, you shall have a save yourproject_sim.sim file, ready
to be “solved”.

12 February 2017 Ulg - FSA 3/33



How to set-up and run a 2D Flow Simulation in Simcenter NX11

✔ Step 4 : Solve the simulation

➔ The solution attributes have to be set : steady state or transient, turbulence
model, use wall function or not, data fields to be retrieved,...

➔ The solver parameters have to be set : relaxation time step, convergence
criteria, number of iteration limits,...

➔ Finally the simulation can be run.

➔ At the end of this step, you shall have run the simulation and the solution
shall have converged (or not) to a result after some iterations.

✔ Step 5 : Analyse the simulation results

➔ The solution verbose and the convergence graph should be reviewed within
the “Solution Monitor” window.

➔ The results can be loaded in order to plot the field of interest :  velocity,
pressure maps, 2D graph along a path, streamlines, ...

➔ A  html  report  with  extra  results  (force  on  a  face  for  instance)  is  also
generated if it was defined at step3.

➔ At the end of  this  step,  you can save again  your  working .sim file  as  a
reference before experimenting with different meshes, constraints or solver
parameters.

Each  step  will  be  explained  with  more  details  using  a  practical  example  in  the
following chapters.

Extra documentation about workflow for Flow simulation can be found here : 

https://docs.plm.automation.siemens.com/tdoc/nx/11/nx_help#uid:xid1128419:index_
advanced:id1245911:id629501
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 1 Create the fluid domain

 1.1 Create an empty model
File>New>under tab “Model” select “Model”>OK

You shall have this view and you are ready to create your part.

 1.2 Create a 2D sketch
Click “Sketch” in the upper left corner

You can keep the default coordinate axis>OK
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 1.3 Draw the fluid domain
Draw the fluid domain and eventual obstacles using the tools under Direct Skecth :
Rectangle, Line, Arc,...

For  this  tutorial  you  should  start  by  drawing  the  following  sketch  using  the  line
command.

You will see that grey dimensions appear automatically in such a way to fully define
your sketch. These are auto-dimensions. You can double-click some and adjust the
value to  make them constraints,  they will  appear  in  dark  blue color.  You can  add
constraints  by  selecting  a  segment  and  then  choosing  “horizontal  dimension”  or
“vertical dimension ”.

You  can  also  add  more  complex  constraints,  like  parallelism,  same  length,
perpendicularity, etc.. by selecting successively different elements and then choosing
suggested constraints.

For instance, if you want a segment to be symmetrically located with respect to the
coordinate axis, you select first the mid-point of the segment (with left mouse click),
then the x-axis arrow (no need to hold down CTRL or SHIFT key) and then a suggestion
of constraint automatically appears “point on curve” and you can click it. You can also
find these constraints under Direct Skecth>More>Skecth Constraints
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For this tutorial you should have the following constraints.

Ideally when you are done with your sketch as here-above, it shouldn't contain any
grey dimensions (auto dimensions) but only dark blue constraints (px=...) set by you.
This means the sketch is fully constrained. The constraint status also appear in the
status bar (bottom of the window).

The next step is to make a round corner. Select the “filet” tool under “Direct Sketch”
and then successively the two inner legs of the corner. Repeat with the two outer legs.
You should have the following sketch with two additional degree of freedom, being the
two arc radius.
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To keep a constant section for the pipe, you will select the two horizontal legs of the
pipe and force them to the same length as shown-here below.

The only remaining degree of freedom is the radius of the outer arc that you should
force to 400mm. The final sketch should appear as follows.
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TIP : The different elements are selected just by clicking them successively, there is
not need to hold down CTRL key. To deselect all  :  press ESC. To deselect one item
only : click it with left mouse holding down SHIFT

TIP : How to navigate
• Clicking the central mouse button and dragging will rotate the view.

• Clicking the central mouse button, then the right mouse button and dragging
will move the view. You can do the same more easily by holding down the SHIFT
key and clicking only the central mouse button and dragging.

• Rolling the mouse wheel will zoom in/out.

• As you work in a sketch plane, if  you unintentionally moved the view out of
plane, you can use short-cut SHIFT+F8 to get back to the top view.

• Other usefull shortcut are available when holding down the right mouse button.

 1.4 Finish the sketch
When you are done with the sketch, Click Finish Sketch in the upper left
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 1.5 Extrude the part
Select your sketch>Click Extrude under Feature toolbox>Choose an extrusion length
of 10mm (for instance)>OK

By rotating the view with the middle mouse button you can verify that you have now a
3D solid body.
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 1.6 Split the body to prepare the meshing
In order to be able to make a consistent meshing with quadrilateral elements, the fluid
domain has to be divided in simple geometries: triangles or quadrilaterals, possibly
with curved edges.

Under Feature toolbox>More>Trim>Split body

Select your body and then under Tool>Section>Select Curve>Click on Sketch Section

Just click OK on the next dialog box to select the same system coordinate (CSYS) you
already used.

Proceed similarly as for the initial sketch. For this tutorial, you should split the body in
three parts by adding two perpendicular lines at the entry and exit of the corner. You
should  also  have  this  new  sketch  fully  constrained,  ideally  by  having  your  new
elements referring to the first sketch geometry. By doing so, if you change a dimension
in  the  first  sketch  later,  this  split  body  and  the  meshing  will  follow  and  adapt
automatically.

TIP : For boundary layer on complex geometry a nice tool to experiment is the “offset
curve”.

When you are done with the sketch, Click Finish Sketch in the upper left

Make sure to tick the box for “Keep Imprinted Edges” under Settings and
click OK.
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By doing so, the software automatically creates Glue Coincident type mesh mating
conditions between the bodies when you switch to the FEM file. You should inspect
these  mating  conditions  and  ensure  that  they  were  created  at  all  appropriate
locations.

For more complex geometry, you can repeat the operations as many time as needed
to be able to create a sound mesh later on.

Make sure you save your model as a yourproject.prt file.

Sketch tutorials can be found here :

https://docs.plm.automation.siemens.com/tdoc/nx/11/nx_help#uid:id1251042

https://docs.plm.automation.siemens.com/tdoc/nx/11/nx_help#uid:xid1128417:index_
sketcher:id188016:id771117

Sketch video examples can be found here :

https://docs.plm.automation.siemens.com/tdoc/nx/11/nx_help#uid:xid1128417:index_
sketcher:id1389302
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 2 Mesh the body

 2.1 Create a mesh file
File>New>under  tab  “Simulation”  select  “Simcenter  Thermal/Fow”  with  type
“Fem”'>OK

Keep the box “Associate to Master Part” ticked.

In the field “Part”, you shall select the part you just
created.

Untick the box “Create Idealized Part”.

This option is used when working in team on the same
part or if the part has to be simplified for the simulation
but the original design has to kept unaltered. 

Select Solver “Simcenter Thermal/Flow” and Analysis
Type “Flow”.

Click OK.
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 2.2 Verify that the different split bodies are connected
First thing to do, is to verify that the different polygons created by the “split body”
command  are  correctly  connected  to  each  other.  Check  the  MMC  (Mesh  Mating
Conditions).

If it appears that two polygon bodies have common face but are not connected, you
can add the connection manually by clicking Mesh Mating under Connections toolbox.

TIP : When you are sure about the connections, you can hide the symbols by unticking
the Connection Collectors  in  the arborescence tree to keep the visualisation  more
clear.

TIP : You can change the colour of your polygons by double clicking the small color box
next to it in the arborescence and rename them to make identification easier later on.

 2.3 Add the meshing constraints on the body edges
Mesh Control>chose in the dropbox Number on Edge/Size on Edge/Biasing on edge
>Select all  edges for which you want to apply the constraints > Click the preview
button > OK.

You  can  set  a  constraint  on  multiple  edges  at  a  time.  For  the  biasing  on  edge
(especially useful for boundary layer), you have to select the orientation (start of start,
end of edge or middle of edge) and it varies from edges to edges depending on the
edge natural direction. 

In this tutorial  we will  apply on the 4 perpendicular section a “bias on edge” with
option “Center of edge”, 30 elements and bias ratio of 1,12 to have smaller elements
close to the wall where the velocity gradients are more important.
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Remark : A matching edge between two polygons should be specified once only.

Next, you force the elements size to be 10mm on the entry and exit lateral sections.
You shall put all those constraints in the same plane, here the upper plane.

12 February 2017 Ulg - FSA 15/33



How to set-up and run a 2D Flow Simulation in Simcenter NX11

Repeat the same operation and set a size on edge of 5mm on the outer arc of the
corner.

Using  Mesh Control>Number on edge you shall  also set the short edges along the
thickness (z-axis) to have one single element, as the simulation is 2D.

TIP : When setting mesh constraints on edge, you should rotate the view to an out of
plane view angle to differentiate between the edges on the lower face and on the
upper face. You should constraint only the edge on one face, for instance all edges on
the upper plane.
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TIP : For more complex geometry, you can set the view to wireframe to view all your
constraints at once. An edge density is shown with a yellow diamond, see here-under.

 2.4 Create 2D meshes
You can now mesh the face by using 2D mapped mesh. Off course you should mesh
the  plane  on  which  you  defined  the  mesh  constraints.  From  experience,  it  is
recommended to map the face one by one.

Mesh>More>2D Mapped Mesh>Click the face where you set the edge constraints

You can select either QUAD4 or TRI3 elements. In this tutorial we select quadrilateral
elements.

When working with quadrilaterals mesh, if you have correctly set the edge constraints,
the “element size” parameter should have no effect and can be left to a default value.

You can click the icon next to “show results” to get the preview before clicking OK.

Mesh all the other polygon faces of the plane similarly.

In more complex geometry, make sure not to over-constrain the mesh. Every time you
generate a 2D mapped mesh with quadrilateral elements, the constraint of one edge
is  reported to  the opposed edge.  This  constraint  appears  as  “Mapped Mesh Edge
Density” in the arborescence and as blue diamond in the main view (see image here-
above). This also means there might be a logical order on how to mesh the different
faces.
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 2.5 Create 2D dependent meshes on the other face
In order to have a pure bidimensional problem, the mesh has to be identical on both
top and bottom faces of the solid.

For  every single  2D mesh,  a  dependant  2D mesh on the opposite side has to be
created.

Mesh> More > 2D dependent> Select the master face with the mesh > Select the
corresponding face on the opposite side > OK.

Repeat the process for all 2D meshes. You might try to map more than one polygon
face at a time to speed up the process if you have many of them but it is not always
possible.

 2.6 Create 3D swept mesh
The 3D mesh can now be created by sweeping the 2D mesh.

Mesh>More>3D Swept Mesh>Click the top face with the 2D mapped mesh, then click
in  the  dialog  box  to  select  the  target  face  and click  on  the  bottom face  of  your
polygon>OK

You should use HEXA8 if you have 2D map with QUAD4 elements.

Here  again,  the  “Source  Element  Size”  parameter  should  have  no  effect  if  you
correctly set a constraint of 1 single element on the edges along thickness.

You  shall  have  only  a  single  element  on  the  thickness  for  a  pure  bidimensional
simulation.
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Proceed similarly for all the polygon bodies.

Verify that you have only one element for the whole thickness and that the top and
bottom meshes match such that the elements are vertical prisms. You can again use
the wireframe view.

Do not forget to save your project as yourproject_fem.fem

Remark : Even if the extension changes from the yourproject.prt, it seems it can't have
the same name and you should append _fem to the file name.
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 3 Specify  material  properties  and  set  the
simulation constraints

 3.1 Create a sim file
File>New>under tab “Simulation” select “Simcenter
Thermal/Fow” with type “Sim”'>OK

In the field “Associated FEM”, you shall select the fem
file you just created.

At this stage under Solver Environment\Analysis type,
it appears “Thermal” instead of “Flow” but you will be
able to change it on the next dialog box.

After changing the Analysis Type to Flow, Click OK, as it will still be possible to change
all these solution attributes before running the simulation.
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 3.2 Set the materials
In the left arborescence, expend the 3D meshes and double-click every single mesh
(1) collector; then double click next to propert\ytype (2) and then select the material
substance within the catalogue (3): water for this tutorial.

Repeat the same for every single 3D mesh.

 3.3 Set the boundary conditions
Define the inlet and outlet

Loads and Conditions>Simulation Object Type>Flow Boundary Conditions>

• Inlet Flow : to set a velocity (input)

• Opening : to set a pressure (output)

In this tutorial, you will set 0,34m/s as input velocity at the extremity of long leg of the
pipe and ambient pressure at the extremity of the short leg.

On the top and bottom face of the solid, you can impose symmetry plane to ensure a
pure bidimensional problem. You can select all faces on one side simultaneously, but
make sure not to select upper and lower faces together.

Loads and Conditions>Simulation Object Type>Symmetry

On the remaining lateral  faces,  you can select  either  Flow Surface\Boundary Flow
surface\slip wall or non-slip wall, or symmetry depending on the problem. At the end
every single face should have a boundary condition. When you use non-slip boundary
surface, make sure to tick “Wall function”.
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You can visualize the boundary conditions and untick the box later in the arborescence
for more clarity.

 3.4 Set the initial conditions
Loads and Conditions > Constraint Type > Initial Conditions

Setting the initial conditions should speed up the convergence to the solution.

In this tutorial, this is not necessary.

 3.5 Prepare report for forces on faces.
At this point, you will prepare the computation of the forces on the corner and the
second leg of the pipe.

Simulation Object Type > Report > Type = Lift & Drag 

Click the surfaces of interest. For this tutorial, select the 6 polygon faces as shown
here-below.

12 February 2017 Ulg - FSA 22/33



How to set-up and run a 2D Flow Simulation in Simcenter NX11

You should select Lift axis to be X and Drag axis to be Y.

In the subpanel “Axes” you should select the coordinate system as previously defined
and chose the correct axis for Drag and Lift.

You  can  also  enter  some data  to  compute  directly  the  aerodynamic  coefficient  if
applicable. This is not the case for this tutorial.

Do not forget to save your project as yourproject_sim.sim

Remark : Even if the extension changes from the yourproject.prt, it seems it can't have
the same name and you should append _sim to the file name.
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 4 Solve the simulation

 4.1 Set the solution attributes
Solution> Solve > Edit Solution Attributes

Make sure Analysis Type is “Flow”

Under Solution Details :

• you can select the Solution Type “Steady state” or “Transient”. In this tutotial,
you should start with steady-state.

• you can select the turbulence model. The common one to be used is k-epsilon.

Under 3D Flow, you should enable Use Wall Function.

Under Results Option, you should tick any data field you want to retrieve.

 4.2 Set the solver parameters
Solution> Solve > Edit Solver Parameters

In some cases, you might need to play with the “steady-state Relaxation Time Step”
and “Time Step” under the 3D Flow Solver tab.

You can also change the Maximum residuals. In order to study the convergence of the
solution based on the mesh refinement, you could put a smaller “Maximum Residuals”.

12 February 2017 Ulg - FSA 24/33



How to set-up and run a 2D Flow Simulation in Simcenter NX11

 4.3  Solve the simulation
Solution>Solve>OK

During  the  computation,  in  the  Solution  Monitor  window,  you  can  click
Graph>Convergence to check the progress of  the computation in real  time And/or
watch the verbose in real-time.

Under  Graph>Track  Results  >  You  can  also  track  in  real-time  min/max/average
velocity/pressure convergence.

Remark : As the simulation is purely bidimensional, the residual for W (velocity along
z-axis) is constant at 10-12. This is a quick check for any mistake that could make the
flow not purely bidimensional.

Once, you could run the simulation and it converged, do not forget to save before
analysing the results and trying different configurations.
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 5 Analyse the simulation results

 5.1 Review the verbose

Click  Yes   to  review all  the  solver  verbose.  There  is  very  valuable  information  to
understand better the solution and how worked the solver.

The logging remain available under a yourproject_sim-Solution_1.log file created in the
main directory.

 5.2 Check the created files
If you have defined a report with Lift&Drag for instance, an html file should have been
created. The same info is available in .csv file.

The  convergence  graphs  are  also  available  afterwards  as  png  image  in  the  main
directory.

 5.3 Set-up key measurements for rapid analysis
Once  you  have  solved  at  least  one  time  the  simulation,  you  can  add  some  key
measures of interest. These values are handy for a quick look on the solution when
varying different solver parameters  or trying different mesh configuration.
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Solution tab> Result Measures>Lower left corner NEW

Pick up values of interest to evaluate validity and convergence of the solution : like
minimum pressure over a surface or maximum velocity over the entire model.

In this tutorial, we will select the min and max velocity and the min and max pressure
over the entire domain, and the average pressure at the inlet.
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 5.4 Plot the results
On the very left tool bar click the second icon to go to post-processing navigator.

Right click on Solution\Flow > Load

In  the  arborescence  under  flow  you  can  access  the  different  data  field:  velocity,
pressure,...

To plot the velocity for instance, right click velocity > Plot

You can edit  the plot  by right-clicking the active Post-view>Edit.  You can plot  iso-
curves, or streamlines, etc.. You can also remove the display of the mesh by selecting,
“Feature” under Edges&Faces\Primary Display\Edges. 

Once you have plotted a data field, like velocity or pressure for instance, you can also
create 2D graph under Post-processing toolbox.

In this tutorial we will plot the velocity profile along the pipe.

Post-processing>Create Graph

Under X Axis, Define by “Path Length”

Under Y Axis, Tick Define By Query Curve

Under the “Query curve” tab, click the top right icon to create a new curve.

Give a name to the curve and select Method “coordinates”

You can then either click the two extremities of the curve on the mesh display or enter
the points coordinates manually.
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Here we will create a curve perpendicular to the pipe at 500mm after the entry. 

Finally, enter a high number of points per segment, preferably much higher than the
number of elements, 100 for instance.

When back in the graph tab, make sure the slider for “Distance to Mesh” is at the
minimum 0,0001 and select the Projection Vector to be along z-axis.
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A small pop-up window will then ask you if you want to plot it in a new window or in an
existing one, chose a new window.

Repeat the same steps to plot the velocity profile at different length along the pipe to
see how the turbulent flow profile goes from flat at the inlet to a parabolic curve as the
boundary layers grow and merge. Within the curve, the profile becomes asymmetric
with higher velocity at the inner side of the curve.

A tutorial on how to plot the solution is available here (steps 6 to 9):

https://docs.plm.automation.siemens.com/data_services/resources/nx/11/nx_help/train
ing/en_US/advanced_sim_tutorial/id741086.html
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 6 Change the design
In  this  paragraph,  we  will  show how to  test  an  alternative  design,  for  instance  a
shorter radius corner.

First click the top-left icon “Return to home” to exit the result analysis and go back to
the simulation navigator.

In  the  arborescence,  under  yourproject_sim.sim\yourproject_fem.fem  double-click
yourpart.prt two times in a row to open it again. Now you can switch between the part,
the mesh and the simulation via the button in the header bar “Switch Window”.

When in the Modeling window (yourproject.prt), select the “Part Navigator” (3 rd icon in
the left vertical toolbar).

Now you can edit your sketch by double-clicking it. Change the radius from 400 to
70mm.

Click finish the sketch.

Switch window to go back to the Simulation.

In the top-left, click “Activate Meshing”.

In  the  top-left,  click  Update,  to  automatically  update  the  meshing  to  the  new
geometry.

Then  again  in  the  top  left  “Activate  the  Simulation”  and  Solve  for  this  new
configuration.

The same process can be used to change the meshing constraints,  if  you want to
refine the meshing for instance. You can jump between the .prt, the .fem and the .sim
files and they should be linked together as you modify them.
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Plot the velocity field using streamlines to see the dead zone after the corner.

After loading the solution, Under Home tab\Solution\Result Manager you will see that
the values are displayed in red, you can select them and click the bottom “Update”
button to get the new values.

Large radius (400mm) Short radius (70mm)

Inlet average pressure 35,9 Pa 75,1 Pa

Maximum velocity 0,395 m/s 0,721 m/s

Maximum pressure 38,0 Pa 81,57 Pa

Minimum pressure -3,0 Pa -284,6 Pa

As expected, you can see that the inlet pressure is higher, more than twice what was
needed for the large radius. Minimum, maximum pressure and maximum velocity are
also higher in absolute values over the domain.
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 7 Extra Resources
NX 11 help menu :

https://docs.plm.automation.siemens.com/tdoc/nx/11/nx_help/#uid:index

Many tutorials are available here :

https://docs.plm.automation.siemens.com/data_services/resources/nx/11/nx_help//trai
ning/en_US/advanced_sim_tutorial/index.html?goto=id557841.html

The Simcenter Flow Solver Reference Manual is available here :

https://docs.plm.automation.siemens.com/data_services/resources/nx/11/nx_help/com
mon/en_US/graphics/fileLibrary/nx/tdoc_advanced_simulation/flowrefman.pdf

A community forum for SimCenter 3D simulation is available here :

http://community.plm.automation.siemens.com/t5/3D-Simulation-Simcenter-3D-
Forum/bd-p/Simcenter_3DSimcenter_forum
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